Car stalls when decelerating

  
Post technical questions and answers about your ride.

Moderators: tpirocz, Aron213, zroc, 87350tpi


Heath_25
Senior Member
Senior Member
 
Posts: 132
Joined: Mon Jun 10, 2002 3:26 pm
Location: Huntsville, AL

Car stalls when decelerating

Postby Heath_25 » Sat Oct 30, 2010 9:43 pm

87 iroc 305 197,000 miles

The car idles, accelerates, and holds a constant speed fine. When I am at a cruising speed, and then let off of the gas to coast, the service engine soon light comes on and will remain on until I shut off the car and turn it back on. Occasionally, when I let off the gas and decelerate for a red light or other stop, the RPMs dip below 500 and the car stalls (while still going a decent speed). What do y'all think is wrong with it? The light has been coming on for a week now, but with no symptoms (stalling) until today. Also, I have trouble seeing how this is related, but right before the first time that the service light turned on, the speedo and odometer went out.

Any ideas?

Thanks,
Heath
Heath
'87 IROC Z  tpi 305: all stock, i love this car
'73 914 Porsche: nice fun ride, old, but fun
'69 Cutlass Supreme: raw power man 350ci V8


mostly crue
Member
Member
 
Posts: 44
Joined: Wed Apr 28, 2010 12:04 am

Re: Car stalls when decelerating

Postby mostly crue » Sun Nov 14, 2010 6:38 pm

Heath,
Does this happen all the time or infrequently? I am having a similar problem, please let me know what you find.
Jeff.


Heath_25
Senior Member
Senior Member
 
Posts: 132
Joined: Mon Jun 10, 2002 3:26 pm
Location: Huntsville, AL

Re: Car stalls when decelerating

Postby Heath_25 » Mon Nov 15, 2010 12:11 am

Jeff,

After a little more driving, it seems that the problem is not getting worse (hopefully). I just need to go get the codes read. I have a guy about an hour and a half away, and I may head there for Thanksgiving, but not sure if I'm taking my car. I'll let you know if I find anything... so far, nothing. Could just be a sensor. The check engine light will only come on after I let off the gas traveling at high speeds. If I keep it under 50 my entire drive, nothing happens, no light. I haven't had a stall in a while though.
Heath
'87 IROC Z  tpi 305: all stock, i love this car
'73 914 Porsche: nice fun ride, old, but fun
'69 Cutlass Supreme: raw power man 350ci V8


joshhull9
Senior Member
Senior Member
 
Posts: 114
Joined: Sun Jan 10, 2010 4:15 pm

Re: Car stalls when decelerating

Postby joshhull9 » Mon Nov 15, 2010 1:24 am

I couldnt tell ya about the service light but i had a problem where mycar was stalling when i was decelerating and it turned out i had vacuum leak.
Image


mostly crue
Member
Member
 
Posts: 44
Joined: Wed Apr 28, 2010 12:04 am

Re: Car stalls when decelerating

Postby mostly crue » Mon Nov 15, 2010 7:29 pm

Josh,
I've gone through all the vacuum lines and double-checked with WD-40. I was reading another post about the coolant temp switch, so I'm off to ebay to purchase the switch.
Jeff.
P.S. Heath, my car's engine light is flickering off/on at different times. Cannot figure this car out.


mostly crue
Member
Member
 
Posts: 44
Joined: Wed Apr 28, 2010 12:04 am

Re: Car stalls when decelerating

Postby mostly crue » Tue Nov 16, 2010 4:02 pm

Coolant temp switch installed, no change.
Jeff.
updated on "cold start issues". Heath I now have the same problem as you. I have now changed the thermostat to a 192 degree and fuel pump relay with no help.
I hope one of us finds the problem soon.


mostly crue
Member
Member
 
Posts: 44
Joined: Wed Apr 28, 2010 12:04 am

Re: Car stalls when decelerating

Postby mostly crue » Wed Nov 17, 2010 3:47 pm

Whala! It seems the vent, (Chevy calls it a ventilator(?)) for the fuel tank had popped off when I replaced the fuel pump causing a vacuum leak. I noticed that the whoosh sound when taking off the gas cap was gone. I also replaced the gas cap thinking this may also cause a problem in the future. I hope this helps.
Jeff.

User avatar
blue89irocz
IROCZONE Team
IROCZONE Team
 
Posts: 4846
Joined: Wed Apr 28, 2004 2:43 pm
Location: Northern Illinois

1989 Chevrolet Camaro

Re: Car stalls when decelerating

Postby blue89irocz » Wed Nov 17, 2010 5:44 pm

To Jeff any Heath, until you get the codes read it could be a number of things. Let us know what codes you have and we can go from there.
1989 Iroc-Z L98 383 Forced induction (In Progress), hardtop, T-56, 9-bolt rear w/ 3.73

Project will be complete in 2030. :wink:


Heath_25
Senior Member
Senior Member
 
Posts: 132
Joined: Mon Jun 10, 2002 3:26 pm
Location: Huntsville, AL

Re: Car stalls when decelerating

Postby Heath_25 » Thu Nov 18, 2010 11:52 pm

Well my guy back home that would read my codes free got tired of his mechanic job and quit... figures. Anybody know who would read codes less than $45? Seems crazy to pay that much just to get a few words of data.
Heath
'87 IROC Z  tpi 305: all stock, i love this car
'73 914 Porsche: nice fun ride, old, but fun
'69 Cutlass Supreme: raw power man 350ci V8


Heath_25
Senior Member
Senior Member
 
Posts: 132
Joined: Mon Jun 10, 2002 3:26 pm
Location: Huntsville, AL

Re: Car stalls when decelerating

Postby Heath_25 » Thu Nov 18, 2010 11:53 pm

And Jeff, I'm glad you figured out my problem! Vacuum leak is at the top of my suspicions too.
Heath
'87 IROC Z  tpi 305: all stock, i love this car
'73 914 Porsche: nice fun ride, old, but fun
'69 Cutlass Supreme: raw power man 350ci V8

User avatar
Airwolf
IROCZONE Team
IROCZONE Team
 
Posts: 1848
Joined: Tue Jan 13, 2004 9:55 pm
Location: Warsaw, Poland

Re: Car stalls when decelerating

Postby Airwolf » Fri Nov 19, 2010 8:44 am

Heath_25 wrote:Anybody know who would read codes less than $45? Seems crazy to pay that much just to get a few words of data.


You can do that on your own.
viewtopic.php?f=1&t=36024

I also had a problem with stalling when decelerating when two of my fuel injectors were shot (leaking).
Image

User avatar
blue89irocz
IROCZONE Team
IROCZONE Team
 
Posts: 4846
Joined: Wed Apr 28, 2004 2:43 pm
Location: Northern Illinois

1989 Chevrolet Camaro

Re: Car stalls when decelerating

Postby blue89irocz » Fri Nov 19, 2010 5:42 pm

You can either do it by yourself, have autozone do it but I never trust them guys or pay the money. When you are paying thousands of dollars for a scan tool you aren't going to scan people's car for free.
1989 Iroc-Z L98 383 Forced induction (In Progress), hardtop, T-56, 9-bolt rear w/ 3.73

Project will be complete in 2030. :wink:


mostly crue
Member
Member
 
Posts: 44
Joined: Wed Apr 28, 2010 12:04 am

Re: Car stalls when decelerating

Postby mostly crue » Sat Nov 20, 2010 7:46 pm

blue89irocz wrote:To Jeff any Heath, until you get the codes read it could be a number of things. Let us know what codes you have and we can go from there.

blue89irocz,
Airwolf pointed me in the right direction with the codes. I found all the info needed to read codes on thirdgen.org in the resources section. I have to tell you the truth, I am still having problems reading the codes, the 3 times on 12 code, then next code, with my ADD it is a real challenge! I will post my codes as soon as I get back to the car.
Thanks,
Jeff.


mostly crue
Member
Member
 
Posts: 44
Joined: Wed Apr 28, 2010 12:04 am

Re: Car stalls when decelerating

Postby mostly crue » Sat Nov 20, 2010 7:49 pm

blue89irocz wrote:You can either do it by yourself, have autozone do it but I never trust them guys or pay the money. When you are paying thousands of dollars for a scan tool you aren't going to scan people's car for free.

My Autozone never would read the pre ODBII cars. Airwolf highlighted the post where I asked for help reading codes.
Jeff.


Heath_25
Senior Member
Senior Member
 
Posts: 132
Joined: Mon Jun 10, 2002 3:26 pm
Location: Huntsville, AL

Re: Car stalls when decelerating

Postby Heath_25 » Fri Dec 31, 2010 1:05 am

Well I figured out that my water pump was on its way out, so I replaced that and fixed the speedometer. The service light stopped coming on, and I do not have the stalling problem any more. I guess the old water pump was making the belt drag? I have no idea. Anyway, thanks to everyone for the advice.
Heath
'87 IROC Z  tpi 305: all stock, i love this car
'73 914 Porsche: nice fun ride, old, but fun
'69 Cutlass Supreme: raw power man 350ci V8


Return to Technical Discussions



Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 2 guests